[bug#36528,1/2] gnu: emacs-polymode: Update to 0.2.
diff mbox series

Message ID 87o927qnux.fsf@odyssey.lafreniere.xyz
State New
Headers show
Series
  • [bug#36528,1/2] gnu: emacs-polymode: Update to 0.2.
Related show

Commit Message

LaFreniere\, Joseph July 6, 2019, 1:44 p.m. UTC
--
Joseph LaFreniere

Comments

Ludovic Court├Ęs July 8, 2019, 11:05 a.m. UTC | #1
"LaFreniere, Joseph" <joseph@lafreniere.xyz> skribis:

>>From 26ff7839d21547afb731a8d6f7ebb68413f4a58e Mon Sep 17 00:00:00 2001
> From: Joseph LaFreniere <joseph@lafreniere.xyz>
> Date: Fri, 5 Jul 2019 19:39:05 -0500
> Subject: [PATCH 1/2] gnu: emacs-polymode: Update to 0.2.
>
> * gnu/packages/emacs-xyz.scm (emacs-polymode): Update to 0.2.
> [source]: Change URL of Git repository to Polymode GitHub project.
> [homepage]: Change URL to polymode GitHub project.
> [description]: Realign text.

Applied, thanks!

Ludo'.

Patch
diff mbox series

From 26ff7839d21547afb731a8d6f7ebb68413f4a58e Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Fri, 5 Jul 2019 19:39:05 -0500
Subject: [PATCH 1/2] gnu: emacs-polymode: Update to 0.2.

* gnu/packages/emacs-xyz.scm (emacs-polymode): Update to 0.2.
[source]: Change URL of Git repository to Polymode GitHub project.
[homepage]: Change URL to polymode GitHub project.
[description]: Realign text.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++------------------
 1 file changed, 10 insertions(+), 18 deletions(-)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b6051c0ac1..b872c36b4b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9168,33 +9168,25 @@  contexts.
 (define-public emacs-polymode
   (package
     (name "emacs-polymode")
-    (version "0.1.5")
+    (version "0.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/vspinu/polymode.git")
+                    (url "https://github.com/polymode/polymode.git")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0wwphs54jx48a3ca6x1qaz56j3j9bg4mv8g2akkffrzbdcb8sbc7"))))
+                "04v0gnzfsjb50bgly6kvpryx8cyzwjaq2llw4qv9ijw1l6ixmq3b"))))
     (build-system emacs-build-system)
-    (arguments
-     `(#:include (cons* "^modes/.*\\.el$" %default-include)
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'set-emacs-load-path 'add-modes-subdir-to-load-path
-           (lambda _
-             (setenv "EMACSLOADPATH"
-                     (string-append (getenv "EMACSLOADPATH")
-                                    ":" (getcwd) "/modes" ":")))))))
-    (home-page "https://github.com/vspinu/polymode")
+    (home-page "https://github.com/polymode/polymode")
     (synopsis "Framework for multiple Emacs modes based on indirect buffers")
-    (description "Polymode is an Emacs package that offers generic support
-for multiple major modes inside a single Emacs buffer.  It is lightweight,
-object oriented and highly extensible.  Creating a new polymode typically
-takes only a few lines of code.  Polymode also provides extensible facilities
-for external literate programming tools for exporting, weaving and tangling.")
+    (description
+     "Polymode is an Emacs package that offers generic support for multiple
+major modes inside a single Emacs buffer.  It is lightweight, object oriented
+and highly extensible.  Creating a new polymode typically takes only a few
+lines of code.  Polymode also provides extensible facilities for external
+literate programming tools for exporting, weaving and tangling.")
     (license license:gpl3+)))
 
 (define-public emacs-polymode-ansible
-- 
2.22.0