[bug#36608,4/9] Update docker-compose to 1.24.1.
diff mbox series

Message ID CACy6W0ANatSiqJW1FVxzRvnjvKvs8Hau56kwgRUNxWCOyOtTxA@mail.gmail.com
State New
Headers show
Series
  • [bug#36608,1/9] Update docker-compose to 1.24.1.
Related show

Commit Message

Jacob MacDonald July 11, 2019, 8:51 p.m. UTC

Patch
diff mbox series

From 5c5e79fa7d9d492e73d66298616f9921c92bace5 Mon Sep 17 00:00:00 2001
From: Jacob MacDonald <jaccarmac@gmail.com>
Date: Thu, 11 Jul 2019 15:41:26 -0500
Subject: [PATCH 4/9] gnu: Add python-requests-2.20.

* gnu/packages/python-web.scm (python-requests-2.20): New variable.
---
 gnu/packages/python-web.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 04f53740e4..72d4eba0ff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1352,6 +1352,22 @@  WebSocket usage in Python programs.")
 than Python’s urllib2 library.")
     (license license:asl2.0)))
 
+;; Some software requires an older version of Requests, notably Docker/Docker
+;; Compose.
+(define-public python-requests-2.20
+  (package (inherit python-requests)
+           (version "2.20.1")
+           (source (origin
+                     (method url-fetch)
+                     (uri (pypi-uri "requests" version))
+                     (sha256
+                      (base32
+                       "0qzj6cgv3k9wyj7wlxgz7xq0cfg4jbbkfm24pp8dnhczwl31527a"))))
+           (propagated-inputs
+            `(("python-urllib3" ,python-urllib3-1.24)
+              ("python-idna" ,python-idna-2.7)
+              ,@(package-propagated-inputs python-requests)))))
+
 ;; Some software requires an older version of Requests, notably Docker
 ;; Compose.
 (define-public python-requests-2.7
-- 
2.22.0