[bug#37017] Add and update Ruby packages.
diff mbox series

Message ID CAAc=MEwYC0gf+=2t86XRtLJx-p8+g0MAj8sSSqO-QpfzBvaD5g@mail.gmail.com
State New
Headers show
Series
  • [bug#37017] Add and update Ruby packages.
Related show

Commit Message

Brian Leung Aug. 13, 2019, 6:39 a.m. UTC
See attached.

Comments

Brian Leung Aug. 13, 2019, 9:53 p.m. UTC | #1
It turns out that one of those recipes needed something else to be updated
first, so I've redone all the commits from before.

I've also added ruby-solargraph, a LSP-compliant server for Ruby, but I'm
not very experienced with Ruby, so I can't quite figure out how to make the
test suite work on Guix.

On Tue, Aug 13, 2019 at 8:39 AM Brian Leung <bkleung89@gmail.com> wrote:

> See attached.
>
Ludovic Courtès Aug. 23, 2019, 9:33 p.m. UTC | #2
Hi Brian,

Brian Leung <bkleung89@gmail.com> skribis:

> It turns out that one of those recipes needed something else to be updated
> first, so I've redone all the commits from before.
>
> I've also added ruby-solargraph, a LSP-compliant server for Ruby, but I'm
> not very experienced with Ruby, so I can't quite figure out how to make the
> test suite work on Guix.

Applied all the patches with minor changes to address lint warnings.

Thanks!

Ludo’.

PS: The MIME type should be “text/x-patch”, not “application/x-patch”.  :-)

Patch
diff mbox series

From 2b9b07c1f551b8d2e116da37e90febe6fe04c91e Mon Sep 17 00:00:00 2001
From: Brian Leung <bkleung89@gmail.com>
Date: Tue, 13 Aug 2019 08:14:16 +0200
Subject: [PATCH 3/3] gnu: ruby-nokogiri: Update to 1.10.4.

* gnu/packages/ruby.scm (ruby-nokogiri): Update to 1.10.4.
---
 gnu/packages/ruby.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 41bbc7d1bc..b4f58c9110 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3648,13 +3648,13 @@  to reproduce user environments.")
 (define-public ruby-nokogiri
   (package
     (name "ruby-nokogiri")
-    (version "1.8.0")
+    (version "1.10.4")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "nokogiri" version))
               (sha256
                (base32
-                "1nffsyx1xjg6v5n9rrbi8y1arrcx2i5f21cp6clgh9iwiqkr7rnn"))))
+                "0nmdrqqz1gs0fwkgzxjl4wr554gr8dc1fkrqjc2jpsvwgm41rygv"))))
     (build-system ruby-build-system)
     (arguments
      ;; Tests fail because Nokogiri can only test with an installed extension,
-- 
2.22.0