[bug#37121,09/40] gnu: exo: Update to 0.12.8.
diff mbox series

Message ID 20190820215043.32077-9-guix@lprndn.info
State New
Headers show
Series
  • [bug#37121,01/40] gnu: libxfce4util: Update to 4.14.0.
Related show

Commit Message

L p R n d n Aug. 20, 2019, 9:50 p.m. UTC
* gnu/packages/xfce.scm (exo): Update to 0.12.8.
[propagated-inputs] Add gtk+-3. Remove gtk+-2.
[inputs] Add gtk+-2.
---
 gnu/packages/xfce.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Patch
diff mbox series

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index f624e87f51..8238df91b9 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -196,7 +196,7 @@  to share commonly used Xfce widgets among the Xfce applications.")
 (define-public exo
   (package
     (name "exo")
-    (version "0.12.6")
+    (version "0.12.8")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -204,17 +204,19 @@  to share commonly used Xfce widgets among the Xfce applications.")
                                   "exo-" version ".tar.bz2"))
               (sha256
                (base32
-                "00qh8ihrf09jvd26kilybihkgvv6rvi0l1bvlldxc99jb7ygy5ql"))))
+                "1ppwi6n40aphh0dqsnfrk234zsp7pl4lkjnspqjxw7m49bka401l"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (propagated-inputs
-     ;; exo-1.pc refers to all these.
-     `(("gtk+" ,gtk+-2)
+     ;; exo-2.pc refers to all these.
+     `(("gtk+-3" ,gtk+)
        ("libxfce4util" ,libxfce4util)))
     (inputs
-     `(("libxfce4ui" ,libxfce4ui)
+     `(;; FIXME Refered to in exo-1.pc but conflict with gtk+-3
+       ("gtk+-2" ,gtk+-2)
+       ("libxfce4ui" ,libxfce4ui)
        ("perl-uri" ,perl-uri)))
     (home-page "https://www.xfce.org/")
     (synopsis "Extension library for Xfce")