[bug#37121,24/40] gnu: xfce4-power-manager: Update to 1.6.5.
diff mbox series

Message ID 20190820215043.32077-24-guix@lprndn.info
State New
Headers show
Series
  • [bug#37121,01/40] gnu: libxfce4util: Update to 4.14.0.
Related show

Commit Message

L p R n d n Aug. 20, 2019, 9:50 p.m. UTC
* gnu/packages/xfce.scm (xfce4-power-manager): Update to 4.6.5.
[inputs] Add gtk+. Remove gtk+-2.
---
 gnu/packages/xfce.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

Patch
diff mbox series

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 72f01f2117..530f2cc116 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -864,7 +864,7 @@  system resources, while still being visually appealing and user friendly.")
 (define-public xfce4-power-manager
   (package
     (name "xfce4-power-manager")
-    (version "1.6.1")
+    (version "1.6.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -872,16 +872,14 @@  system resources, while still being visually appealing and user friendly.")
                                   name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "0sv5927q8jxvdfx7b06f8s7qyq3qa1nqn0b8c1b9bf234d2jba0y"))))
+                "0x3s2bdwfhp65dz5yn3k43j99ywqlsvrpz3pqmgwm0dik5wbdb8h"))))
     (build-system gnu-build-system)
-    (arguments
-     '(#:configure-flags '("--enable-gtk3")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (inputs
-     `(("lbxrandr" ,libxrandr)
-       ("gtk+" ,gtk+-2)
+     `(("libxrandr" ,libxrandr)
+       ("gtk+" ,gtk+)
        ("upower" ,upower)
        ("libnotify" ,libnotify)
        ("libxfce4ui" ,libxfce4ui)))