[bug#37367,2/3] gnu: Add kqtquickcharts.
diff mbox series

Message ID 20190910095231.24326-2-efraim@flashner.co.il
State New
Headers show
Series
  • Add learn-to-type programs
Related show

Commit Message

Efraim Flashner Sept. 10, 2019, 9:52 a.m. UTC
* gnu/packages/kde.scm (kqtquickcharts): New variable.
---
 gnu/packages/kde.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Ludovic Courtès Sept. 16, 2019, 8:33 a.m. UTC | #1
Hello Efraim,

Efraim Flashner <efraim@flashner.co.il> skribis:

> +    (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
> +    (synopsis "Interactive charts for Qt Quick")
> +    (description
> +     "A QtQuick plugin to render beautiful and interactive charts.")

Nitpick: please write a full sentence here.

Other than that the 3 patches LGTM, thanks!

Ludo’.

Patch
diff mbox series

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index f2261f7f98..c80da7d796 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -602,3 +602,27 @@  communicate with each other.  Here's a few things KDE Connect can do:
 @end enumerate")
     (properties `((upstream-name . "kdeconnect-kde")))
     (license (list license:gpl2 license:gpl3)))) ; dual licensed
+
+(define-public kqtquickcharts
+  (package
+    (name "kqtquickcharts")
+    (version "19.08.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/applications/"
+                            version "/src/kqtquickcharts-" version ".tar.xz"))
+        (sha256
+         (base32
+          "1j3rivvh4sa94lsd0hi4xfvcikl05zrqd7634wxyaxs718ais6dg"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
+    (synopsis "Interactive charts for Qt Quick")
+    (description
+     "A QtQuick plugin to render beautiful and interactive charts.")
+    (license license:lgpl2.1+)))