[bug#37595,1/3] gnu: ecl: Do not compile the deprecated MIT-RT.
diff mbox series

Message ID 20191003090113.29040-1-glv@posteo.net
State New
Headers show
Series
  • Some fixes for ecl-* Common Lisp packages
Related show

Commit Message

Guillaume Le Vaillant Oct. 3, 2019, 9:01 a.m. UTC
Compiling the rt bundled with ECL prevents the ecl-rt package from compiling
properly, as ECL thinks it has already been compiled.

* gnu/packages/lisp.scm (ecl)[arguments]: Add '--without-rt' to
  'configure-flags'.
---
 gnu/packages/lisp.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Patch
diff mbox series

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index ba009bb7a6..68e27948ca 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -217,7 +217,8 @@  interface to the Tk widget system.")
               ("libgc" ,libgc)
               ("libffi" ,libffi)))
     (arguments
-     '(#:tests? #t
+     '(#:configure-flags '("--without-rt")
+       #:tests? #t
        #:parallel-tests? #f
        #:phases
        (modify-phases %standard-phases