[bug#37767] gnu: pwsafe: Update to 3.5.0
diff mbox series

Message ID 87zhi1c2rr.fsf@yahoo.de
State New
Headers show
Series
  • [bug#37767] gnu: pwsafe: Update to 3.5.0
Related show

Commit Message

Tobias Geerinckx-Rice via Guix-patches via Oct. 15, 2019, 5:55 p.m. UTC
Hi Guix,
pwsafe fails to build since the last glibc update.
There is a new release of pwsafe available that fixes the problem.
The attached patch updates pwsafe to 3.5.0 and gets the package building
again.
Let me know if there is something wrong with it.

Tim.

Comments

Efraim Flashner Oct. 15, 2019, 7:31 p.m. UTC | #1
On Tue, Oct 15, 2019 at 07:55:04PM +0200, Tim Gesthuizen via Guix-patches via wrote:
> Hi Guix,
> pwsafe fails to build since the last glibc update.
> There is a new release of pwsafe available that fixes the problem.
> The attached patch updates pwsafe to 3.5.0 and gets the package building
> again.
> Let me know if there is something wrong with it.
> 
> Tim.
> 

Patch looks good. The only change I made was to move googletest from
inputs to native-inputs.

Patch
diff mbox series

From cfe5a34a80129e1b67cccb016991ae598da234ab Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Tue, 15 Oct 2019 19:45:13 +0200
Subject: [PATCH] gnu: pwsafe: Update to 3.5.0

* gnu/packages/password-utils.scm (pwsafe): Update to 3.5.0 and use
  git-file-name.
---
 gnu/packages/password-utils.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index ff13be24db..954bb27181 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
-;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -183,7 +183,7 @@  algorithms AES or Twofish.")
 (define-public pwsafe
   (package
     (name "pwsafe")
-    (version "3.48.0")
+    (version "3.50.0")
     (home-page "https://www.pwsafe.org/" )
     (source
      (origin
@@ -191,8 +191,8 @@  algorithms AES or Twofish.")
        (uri (git-reference
              (url "https://github.com/pwsafe/pwsafe.git")
              (commit version)))
-       (sha256 (base32 "0hxv23yh76liggxbjn4m132z15sklra8ms341xgzl4n5vjx30ihi"))
-       (file-name (string-append name "-" version "-checkout"))))
+       (sha256 (base32 "01kfssd2vr64yh4dqhch58x36n3aj3hpj5n560f41rsxym69c6qs"))
+       (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (native-inputs `(("gettext" ,gettext-minimal)
                      ("perl" ,perl)
-- 
2.23.0