[bug#39312] gnu: Add chatty.
diff mbox series

Message ID 20200203105506.17445-1-jonathan.brielmaier@web.de
State Accepted
Headers show
Series
  • [bug#39312] gnu: Add chatty.
Related show

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jonathan Brielmaier Feb. 3, 2020, 10:55 a.m. UTC
From: Jonathan Brielmaier <jonathan.brielmaier@web.de>

* gnu/packages/messaging.scm (chatty): New variable.
---
 gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

--
2.25.0

Comments

Jakub Kądziołka Feb. 15, 2020, 1:17 p.m. UTC | #1
On Mon, Feb 03, 2020 at 11:55:06AM +0100, jonathan.brielmaier@web.de wrote:
> From: Jonathan Brielmaier <jonathan.brielmaier@web.de>
> 
> * gnu/packages/messaging.scm (chatty): New variable.
> ---
>  gnu/packages/messaging.scm | 37 +++++++++++++++++++++++++++++++++++++
>  1 file changed, 37 insertions(+)

Hi, I installed the package into my user profile, and all the icons had
the "image not found" icon. After I installed adwaita-icon-theme
separately, the icons showed up properly. Maybe you need
adwaita-icon-theme in the propagated-inputs? But, if so, I'm confused as
to why hicolor-icon-theme is being propagated. Maybe both are needed,
but that seems weird.

> +   (native-inputs
> +     `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
> +       ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
> +       ("folks" ,folks)
> +       ("gettext" ,gettext-minimal)
> +       ("glib:bin" ,glib "bin")
> +       ("gtk+:bin" ,gtk+ "bin")
> +       ("libgcrypt" ,libgcrypt)
> +       ("libgee" ,libgee)
> +       ("libhandy" ,libhandy)
> +       ("pidgin" ,pidgin)
> +       ("pkg-config" ,pkg-config)
> +       ("sqlite" ,sqlite)))
Most of these should not be in native-inputs, but normal inputs.
See '(guix)package Reference':

|         The distinction between ‘native-inputs’ and ‘inputs’ is
|         necessary when considering cross-compilation.  When
|         cross-compiling, dependencies listed in ‘inputs’ are built for
|         the _target_ architecture; conversely, dependencies listed in
|         ‘native-inputs’ are built for the architecture of the _build_
|         machine.
|
|         ‘native-inputs’ is typically used to list tools needed at
|         build time, but not at run time, such as Autoconf, Automake,
|         pkg-config, Gettext, or Bison.

Regards,
Jakub Kądziołka

Patch
diff mbox series

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 839f718134..0a45711ee6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -55,6 +56,7 @@ 
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages enchant)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -1995,4 +1997,39 @@  support for high performance Telegram Bot creation.")
       (home-page "https://core.telegram.org/tdlib")
       (license license:boost1.0))))

+(define-public chatty
+ (package
+   (name "chatty")
+   (version "0.1.7")
+   (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://source.puri.sm/Librem5/chatty.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1prqd2dnib3j12pjiplzr2rim9q617vmvzv76lgmz0n3bmp7v7ma"))))
+   (build-system meson-build-system)
+   (native-inputs
+     `(("desktop-file-utils" ,desktop-file-utils) ;for update-desktop-database
+       ("evolution-data-server" ,evolution-data-server) ;libebook-contacts
+       ("folks" ,folks)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")
+       ("gtk+:bin" ,gtk+ "bin")
+       ("libgcrypt" ,libgcrypt)
+       ("libgee" ,libgee)
+       ("libhandy" ,libhandy)
+       ("pidgin" ,pidgin)
+       ("pkg-config" ,pkg-config)
+       ("sqlite" ,sqlite)))
+   (propagated-inputs
+     `(("hicolor-icon-theme" ,hicolor-icon-theme)))
+   (synopsis "Mobile client for XMPP and SMS messaging")
+   (description "Chatty is a chat program for XMPP and SMS.  It works on mobile
+as well as on desktop platforms.  It's based on libpurple and ModemManager.")
+   (home-page "https://source.puri.sm/Librem5/chatty")
+   (license license:gpl3+)))
+
 ;;; messaging.scm ends here