[bug#39737] gnu: qemu-minimal-2.10: Use minimal dependencies from qemu-minimal.
diff mbox series

Message ID 20200222143525.1181-1-janneke@gnu.org
State Accepted
Headers show
Series
  • [bug#39737] gnu: qemu-minimal-2.10: Use minimal dependencies from qemu-minimal.
Related show

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jan Nieuwenhuizen Feb. 22, 2020, 2:35 p.m. UTC
Without this patch qemu-minimal-2.10 is not really minimal; it depends on
cups, ffmpeg, ghostscript, gstreamer, gtk, spice, ...

* gnu/packages/virtualization.scm (qemu-minimal-2.10): Use minimal
dependencies from qemu-minimal.
---
 gnu/packages/virtualization.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Marius Bakke Feb. 24, 2020, 8:27 p.m. UTC | #1
Jan Nieuwenhuizen <janneke@gnu.org> writes:

> Without this patch qemu-minimal-2.10 is not really minimal; it depends on
> cups, ffmpeg, ghostscript, gstreamer, gtk, spice, ...

Good catch, LGTM ...

>
> * gnu/packages/virtualization.scm (qemu-minimal-2.10): Use minimal
> dependencies from qemu-minimal.

... though I'd write this as

[native-inputs]: Inherit from QEMU-MINIMAL instead of QEMU.
[inputs]: Likewise.
Jakub Kądziołka March 1, 2020, 8:51 p.m. UTC | #2
On Sat, Feb 22, 2020 at 03:35:25PM +0100, Jan Nieuwenhuizen wrote:
> Without this patch qemu-minimal-2.10 is not really minimal; it depends on
> cups, ffmpeg, ghostscript, gstreamer, gtk, spice, ...
> 
> * gnu/packages/virtualization.scm (qemu-minimal-2.10): Use minimal
> dependencies from qemu-minimal.
> ---
>  gnu/packages/virtualization.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Thanks, pushed as 97d491a902d294af79c1f0e997029d6872517d5b after
applying Marius's commit message suggestion.
Jakub Kądziołka March 1, 2020, 8:53 p.m. UTC | #3
It seems I have encountered a race condition in my workflow. The proper
commit ID is 2d79250d1aa32fbff5aae0b1d00fcb44cab453e1.

Patch
diff mbox series

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index d3f474d17a..b8d85e03a4 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -303,10 +303,10 @@  server and embedded PowerPC, and S390 guests.")
               (search-patches "qemu-glibc-2.27.patch"))))
     ;; qemu-minimal-2.10 needs Python 2. Remove below once no longer necessary.
     (native-inputs `(("python-2" ,python-2)
-                     ,@(fold alist-delete (package-native-inputs qemu)
+                     ,@(fold alist-delete (package-native-inputs qemu-minimal)
                              '("python-wrapper" "python-sphinx"))))
     (inputs
-     (fold alist-delete (package-inputs qemu)
+     (fold alist-delete (package-inputs qemu-minimal)
            ;; Disable seccomp support, because it's not required for the GRUB
            ;; test suite, and because it fails with libseccomp 2.4.2 and later.
            '("libseccomp"))))))