[bug#39751,core-updates] gnu: swig: Use guile-3.0 instead of guile-2.2.
diff mbox series

Message ID 20200223062942.17171-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series
  • [bug#39751,core-updates] gnu: swig: Use guile-3.0 instead of guile-2.2.
Related show

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Arun Isaac Feb. 23, 2020, 6:29 a.m. UTC
* gnu/packages/swig.scm (swig)[native-inputs]: Replace guile-2.2 with
guile-3.0.
---
 gnu/packages/swig.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Marius Bakke March 18, 2020, 6:26 p.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> writes:

> * gnu/packages/swig.scm (swig)[native-inputs]: Replace guile-2.2 with
> guile-3.0.

I pushed this on your behalf in commit
e607cc3a479b39d11e9d2b5979b9719e133008a0 along with some other
last-minute core-updates changes.
Arun Isaac March 19, 2020, 6:32 a.m. UTC | #2
> I pushed this on your behalf in commit
> e607cc3a479b39d11e9d2b5979b9719e133008a0 along with some other
> last-minute core-updates changes.

Thank you!

Patch
diff mbox series

diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index 3de6343da8..86c1407da9 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,7 +58,7 @@ 
     (native-inputs `(("boost" ,boost)
                      ("pcre" ,pcre "bin")       ;for 'pcre-config'
                      ;; The following are for tests and examples:
-                     ("guile" ,guile-2.2)
+                     ("guile" ,guile-3.0)
                      ("perl" ,perl)))
                      ;;("python" ,python-wrapper)
     (inputs `(("pcre" ,pcre)))