[bug#42081] Upgrade xpra to 4.0.2
diff mbox series

Message ID 20200627132655.GA1396@noor.fritz.box
State New
Headers show
Series
  • [bug#42081] Upgrade xpra to 4.0.2
Related show

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Lars-Dominik Braun June 27, 2020, 1:26 p.m. UTC
Hi,

the following patchset upgrade xpra to version 4.0.2, which will finally
use Python 3 and GTK 3. It removes the Python 2 variants of PyOpenGL,
because xpra is the only dependent. I’ve been running this package for a
week now and connected to both version 4 and version 3 on an Ubuntu
machine, which still works. OpenGL also works, despite failing tests for
PyOpenGL.

Rutger: You have been working on xpra in the past. Could you take a
look and make sure I did not break any use case?

Cheers,
Lars

Comments

Ludovic Courtès July 11, 2020, 2:15 p.m. UTC | #1
Hi Lars-Dominik,

Lars-Dominik Braun <lars@6xq.net> skribis:

> the following patchset upgrade xpra to version 4.0.2, which will finally
> use Python 3 and GTK 3. It removes the Python 2 variants of PyOpenGL,
> because xpra is the only dependent. I’ve been running this package for a
> week now and connected to both version 4 and version 3 on an Ubuntu
> machine, which still works. OpenGL also works, despite failing tests for
> PyOpenGL.
>
> Rutger: You have been working on xpra in the past. Could you take a
> look and make sure I did not break any use case?

Rutger has been inactive in Guix for a few months (last commit in
Sep. 2019).  If these patches work for you, I suggest applying them.
If it turns out to break another use case, we can always fix it up
afterwards.

WDYT?

Thanks,
Ludo’.
Lars-Dominik Braun July 12, 2020, 6:12 a.m. UTC | #2
Hi Ludo,

> Rutger has been inactive in Guix for a few months (last commit in
> Sep. 2019).  If these patches work for you, I suggest applying them.
> If it turns out to break another use case, we can always fix it up
> afterwards.
oh, I did not know that. Sure, go ahead and feel free to CC me if any
problems arise.

Lars

Patch
diff mbox series

From ca8c4504f025ddd6ad67cf0fe4471c2dd1fa89c9 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <lars@6xq.net>
Date: Sat, 27 Jun 2020 15:14:25 +0200
Subject: [PATCH 5/6] gnu: python2-pyopengl-accelerate: Remove.

* gnu/packages/python-xyz.scm (python2-pyopengl-accelerate): Remove
  variable.
---
 gnu/packages/python-xyz.scm | 16 ----------------
 1 file changed, 16 deletions(-)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 318d55360b..c4eb1cd4f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15346,22 +15346,6 @@  related APIs.  The binding is created using the standard @code{ctypes}
 library.")
    (license license:bsd-3)))
 
-(define-public python2-pyopengl-accelerate
-  (package
-    (inherit python2-pyopengl)
-    (name "python2-pyopengl-accelerate")
-    (version "3.1.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "PyOpenGL-accelerate" version))
-       (sha256
-        (base32
-         "0464c1ifzk0k92lyndikmvzjgnx1y25r7bkkc8pnxm4kp1q4czwj"))))
-    (synopsis "Acceleration code for PyOpenGL")
-    (description
-     "This is the Cython-coded accelerator module for PyOpenGL.")))
-
 (define-public python-pyopengl
   (package
     (name "python-pyopengl")
-- 
2.26.2