[bug#42097] gnu: artanis: Use guile2.2 version of guile-redis.
diff mbox series

Message ID 20200627224203.13384-1-masaya@tojo.tokyo
State New
Headers show
Series
  • [bug#42097] gnu: artanis: Use guile2.2 version of guile-redis.
Related show

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Masaya Tojo June 27, 2020, 10:42 p.m. UTC
* gnu/packages/guile-xyz.scm (artanis)[propagated-inputs]: Change from
guile-redis to guile2.2-redis.
---
 gnu/packages/guile-xyz.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Efraim Flashner June 28, 2020, 7:56 a.m. UTC | #1
On Sun, Jun 28, 2020 at 07:42:03AM +0900, Masaya Tojo wrote:
> * gnu/packages/guile-xyz.scm (artanis)[propagated-inputs]: Change from
> guile-redis to guile2.2-redis.
> ---
>  gnu/packages/guile-xyz.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index f8e59b0b21..5416b30c2e 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -28,6 +28,7 @@
>  ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
>  ;;; Copyright © 2020 Julien Lepiler <julien@lepiller.eu>
>  ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
> +;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -157,7 +158,7 @@
>      (propagated-inputs
>       `(("guile-json" ,guile-json-1)
>         ("guile-readline" ,guile2.2-readline)
> -       ("guile-redis" ,guile-redis)))
> +       ("guile-redis" ,guile2.2-redis)))
>      (native-inputs
>       `(("bash"       ,bash)         ;for the `source' builtin
>         ("pkgconfig"  ,pkg-config)
> -- 
> 2.26.2
> 

Should guile-json-1 be switched to guile2.2-json-1 also?
Masaya Tojo June 28, 2020, 10:58 a.m. UTC | #2
Hello,

Thank you for reviewing my patch.

> Should guile-json-1 be switched to guile2.2-json-1 also?

Guile-json-1 seem version of guile2.2. I search for guile2.2-json-1, but it
does not exist yet.

So, I think that it's not necessary.

Regards,
Efraim Flashner June 29, 2020, 6:21 a.m. UTC | #3
On Sun, Jun 28, 2020 at 07:58:37PM +0900, Masaya Tojo wrote:
> 
> Hello,
> 
> Thank you for reviewing my patch.
> 
> > Should guile-json-1 be switched to guile2.2-json-1 also?
> 
> Guile-json-1 seem version of guile2.2. I search for guile2.2-json-1, but it
> does not exist yet.
> 
> So, I think that it's not necessary.
> 

Agreed. I added a comment mentioning that guile-json-1 was already using
guile-2.2 so no one else gets confused and pushed the patch. Thanks!

Patch
diff mbox series

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index f8e59b0b21..5416b30c2e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;; Copyright © 2020 Julien Lepiler <julien@lepiller.eu>
 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -157,7 +158,7 @@ 
     (propagated-inputs
      `(("guile-json" ,guile-json-1)
        ("guile-readline" ,guile2.2-readline)
-       ("guile-redis" ,guile-redis)))
+       ("guile-redis" ,guile2.2-redis)))
     (native-inputs
      `(("bash"       ,bash)         ;for the `source' builtin
        ("pkgconfig"  ,pkg-config)