[bug#42117,13/17] gnu: Add r-hunspell.
diff mbox series

Message ID 20200629055042.8565-13-peterloleungyau@gmail.com
State New
Headers show
Series
  • [bug#42117,01/17] gnu: Add r-hardhat.
Related show

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Peter Lo June 29, 2020, 5:50 a.m. UTC
* gnu/packages/cran.scm (r-hunspell): New variable.
---
 gnu/packages/cran.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Patch
diff mbox series

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 26c3c1e562..3c98bc2753 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22704,3 +22704,33 @@  The tokenizers have a consistent interface, and the package is built
 on the @code{stringi} and @code{Rcpp} packages for fast yet correct
 tokenization in 'UTF-8'.")
     (license license:expat)))
+
+(define-public r-hunspell
+  (package
+    (name "r-hunspell")
+    (version "3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (cran-uri "hunspell" version))
+        (sha256
+          (base32
+            "0mwqw5p0ph083plm2hr2hqr50bjg2dw862dpsfm4l2fgyy3rryq1"))))
+    (properties `((upstream-name . "hunspell")))
+    (build-system r-build-system)
+    (propagated-inputs
+      `(("r-digest" ,r-digest) ("r-rcpp" ,r-rcpp)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page
+      "https://github.com/ropensci/hunspell#readmehttps://hunspell.github.io")
+    (synopsis
+      "High-Performance Stemmer, Tokenizer, and Spell Checker")
+    (description
+      "Low level spell checker and morphological analyzer based on the
+famous @code{hunspell} library <https://hunspell.github.io>.  The
+package can analyze or check individual words as well as parse text,
+latex, html or xml documents.  For a more user-friendly interface use
+the @code{spelling} package which builds on this package to automate
+checking of files, documentation and vignettes in all common
+formats.")
+    (license (list license:gpl2 license:lgpl2.1 license:mpl1.1))))