[bug#33850] gnu: Remove obsolete package gpgmepp.

Message ID 20181223174606.5440-1-h.goebel@crazy-compilers.com
State New
Headers show
Series
  • [bug#33850] gnu: Remove obsolete package gpgmepp.
Related show

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Hartmut Goebel Dec. 23, 2018, 5:46 p.m. UTC
This package is unused, is part of gpgme since version 1.7 and has been marked
as superseded since 18 months now.

* gnu/packages/kde-frameworks.scm(gpgmepp): Remove variable.
---
 gnu/packages/kde-frameworks.scm | 27 ---------------------------
 1 file changed, 27 deletions(-)

Comments

Ludovic Courtès Dec. 24, 2018, 3:10 p.m. UTC | #1
Hi Hartmut,

Hartmut Goebel <h.goebel@crazy-compilers.com> skribis:

> This package is unused, is part of gpgme since version 1.7 and has been marked
> as superseded since 18 months now.
>
> * gnu/packages/kde-frameworks.scm(gpgmepp): Remove variable.

Applied, thank you!

Ludo’.

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 645252288..e0f746534 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -209,33 +209,6 @@  Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
     ;; license: source files mention "either version 2.1 or 3"
     (license (list license:lgpl2.1 license:lgpl3))))
 
-(define-public gpgmepp
-  (package
-    (name "gpgmepp")
-    (version "16.08.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://kde/stable/applications"
-                    "/" version "/src/"
-                    name "-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0828qlhdi1i26n2xgyb01c0q77m6jlppbxv6mprryxq0ma88940a"))))
-    (build-system cmake-build-system)
-    (native-inputs
-     `(("extra-cmake-modules" ,extra-cmake-modules)))
-    (propagated-inputs
-     `(("boost" ,boost)
-       ("gpgme" ,gpgme)))
-    (inputs
-     `(("qtbase" ,qtbase)))
-    (home-page "https://community.kde.org/Frameworks")
-    (synopsis "C++ bindings/wrapper for gpgme")
-    (description "C++ bindings/wrapper for gpgme.")
-    (license license:lgpl2.1+)
-    (properties `((superseded . ,gpgme)))))
-
 (define-public kpmcore
   (package
     (name "kpmcore")